Bug with creation of CTX file?

#1

Hi, I’ve realised today why my project runs soooo slowly. I have a Vensim model with TIME in years and TIME STEP 0.03125 and a run duration of 48 years, so lot’s of data. Regardless of the value I place in " Report every nth step", the graphs still load up ALL the data points, so are too slow to be useful.

I used the help system to see that settings are saved in a CTX file and that, crucially, this must be the same name as the model. Each time I release a new model version with new name and upload to Forio, however, no new CTX file is created, so all the settings are being saved in a CTX file that is ignored at run time. Deleting the old CTX file and recreating the settings, works.

On a related note; although at run time, the " Report every nth step" value works, it does not come into play when editing the pages, so each graph is being updated with every calculation, while I am trying to edit it. This essentially locks up my computer until it can catch up.

Now I’m aware of the CTX issue I can work around it. However, when designing the pages, the fact that every data point is being drawn every time I try to change anything on the page, is very frustrating.
Hopefully I am doing something wrong!

Thanks for your help.

Lee

0 Likes

#2

Hi Lee,

Thanks for the note. (sorry for the late reply). Yes - that’s correct. The settings are stored in a context file. If you upload a new model, it will not recognize the new context file. You can either keep the model name the same (e.g. rename it before you upload to a generic name like “model.vmf” each time you upload), or manually download, rename, and reupload the context file before going to the interface builder.

“Report every nth step” sets the property “reportPer” in the context file. This should apply to both the runs in the final simulation but also in the interface builder. This only kicks in for new runs, however. It’s like that what is happening is that when you make a new model/context file, and then change reportPer, it’s still got the old run going. I’ll pass along this feedback to the developers. Waiting until 30m of idle time have passed (then logging out/back in) should help. Let us know if this works.

WILL

0 Likes

#3

Thanks for the reply Will, all seems well now so there’s nothing for me to try in order to fix it.

I did find one cause of real hassle when using Interface Builder though. I use Keeper Security for my online passwords and, when it is active, it causes Forio Interface Builder to become non-responsive if there are text input objects on the page being viewed. Once I made Keeper more passive (i.e. it now just sits in the background and doesn’t try to keep filling in passwords for text input boxes in Forio), everything became fine again. Lesson learned :wink:

Lee

0 Likes