Facilitator Interface and Slow to load/refresh pages

Hello! I am creating my first facilitator interface and running into a few problems. I tried adding some variables to the “settings” page, and appear to have broken something. It wouldnt save, and now I can’t open the page.

This may or may not be connected to another issue - at some point today, the interface started getting extremely sluggish. It takes 30 seconds or more to save, sometimes fails to save, and when I enter an input variable I see a blue circle that spins for about 15 seconds before it will refresh the page. Only my work on epicenter is affected - it doesn’t appear to be my general internet connection or speed.

Can you help?

I solved the slow performance issue - it seems I had deleted some name definitions in my Excel model and that was causing problems.

However, I am completely stuck with the facilitator interface. It appears the facilitator interface pages are corrupt and I don’t know how to fix it without losing an entire days’ work on my user interface. I do have a backup, can anyone tell me which files I should try to restore first?

Hi Kristin,

Good news that you figured out the missing variable issue.

The facilitator pages are in the pages/fac directory. You can replace them. If the file names changed you may also need to edit the navigation in the interface builder.


1 Like